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1 Introduction

1.1 Features

BiotSavart is a general purpose interactive program to calculate magnetic
fields resulting from collections of current-carrying conductors. Features of
the program are

e general conductor shapes

— filamentary loop
— cylindrical solenoid (thick, thin, or pancake)

— revolved surface

filamentary wire of arbitrary path

— racetrack coil
e conductor descriptions can be entered interactively or read from files

e two or three-dimensional graphical display of the conductor configu-
ration

e calculation of vector field profile along a specified trajectory
e two-dimensional profiling of field with contour plot
e calculated field profiles may be written to disk for post-processing

e field profiles update automatically when changes are made to conduc-
tors or currents

1.2 What you need

Version 2.2 of BiotSavart requires a computer running MacOS system 7 or
8 and at least 1 MB of application memory. Versions exist for PowerPC and
68K machines.



2 Using the program

2.1 Starting and quitting

To start BiotSavart, open (or double-click) the application icon. Alter-
natively, you can open an existing BiotSavart document. The conductors
described in the document will be displayed on the Configuration window.
Field probes, if any, will not be recalculated, in order to allow you to modify
the configuration before embarking on a time-consuming computation.

In order to exit BiotSavart, choose Quit (38Q) from the File menu. If the
configuration has been changed since it was last saved, you will be asked
whether or not to save the changes.

2.2 Adding conductors

If there is no configuration window, create one by choosing New (38N)
from the File menu.

Conductors are added to the configuration using the Config menu. Conduc-
tor types are Loop, Solenoid, Revolved, Wire, and Racetrack. When-
ever you add a conductor an edit dialog window will appear to allow you
to change the specifications (this is described in detail in section 5). After
modifying the conductor, register the changes using the Set button. The
Done button is the same as Set, but also dismisses the edit dialog.

Conductors may also be read from other BiotSavart documents or your own
files using the Read file... command on the Config menu. This command
will prompt for a file to read, and extract from it the conductor descriptions
and current supply values. Probes are not extracted. Section 9 describes
how to make your own conductor files.

2.3 Selecting conductors

To select a conductor, click on its picture on the configuration window. The
name of the conductor will appear at the bottom of the window. Clicking
with the shift key depressed adds the conductor to the selection list (if it is



already selected, this removes it from the list). Selected objects are drawn
red. You can also tell which conductors are selected by looking at the
Modify menu — the name of each selected conductor will be checkmarked.

2.4 Deleting conductors

Selected conductors can be deleted by selecting Cut (§8X) or Clear from
the Edit menu.

2.5 Modifying conductors

In order to make changes to a conductor, you must create an edit window for
the conductor. There are several ways to do this. The fastest is to double-
click the conductor on the configuration window. Choosing the conductor
by name from the Modify menu will accomplish the same thing. Also, if
one or more conductors is selected, the Modify command (38I) on the Edit
menu will create an edit window for each selected conductor.

Changes to the conductor dialog parameters do not take effect until they
are registered with the configuration by using the Set or Done buttons.
Note that this registers the changes with the configuration database, but
writes nothing to disk unless the Autosave option is set. Changes may be
discarded before saving by using the Cancel button to dismiss the dialog.

The name of the conductor may be changed when its edit window is active
by using the Change Name... command on the Edit menu.

2.6 Probing the field

To measure and display the magnetic field, you create field probes using the
Config menu. There are two types of probes: Linear, a one-dimensional
probe, and Planar, a two-dimensional probe. When a probe is created an
edit window appears containing the description of the probe and the format
of the display of the calculated field profile. For the Linear probe, the
specification includes a description of the path through space along which
the field is to be calculated. The motion commands are documented in



section 8.

Each probe has a result window in which it displays the calculated field
profile. The name of the window is the name of the field probe preceded by
the symbol II (for product).

Selection, deletion, and modification of probes is done in the same manner
as conductors.

2.7 Saving the configuration

In order to save a new or modified configuration to disk, use the Save com-
mand (§68S) on the File menu. If you are working on an existing BiotSavart
document, then this will overwrite the old version of the file. If instead you
wish to save the configuration under a new name, then use the Save As...
command.

2.8 Field calculation

After making changes to the configuration, you will want to recompute the
magnetic field, to update the field probe displays. To do this, use the Re-
compute command (F8R) on the Field menu. This command is only
enabled when the field needs to be recalculated.

If AutoRecompute is enabled, the program will recalculate the field when-
ever a conductor or probe in modified, e.g., from an edit dialog. Selecting
AutoRecompute from the Field menu toggles it between enabled (ticked)
and disabled (not ticked).

If you want to modify several conductors or probes before recalculation, dis-
able AutoRecompute, make and save the modifications, and then trigger
the recalculation by re-enabling AutoRecompute or by using the Recom-
pute command (FER).

During the field calculation, the cursor will be cycling through an action
sequence. This indicates that the program may be interrupted by holding
down the 38 button and typing a period (.).



2.9 Current supplies

The current passing through the wires of a conductor is determined by its
current supply. The present version of BiotSavart requires conductors to
have an external current supply. The use of external current supplies greatly
accelerates magnetic field recalculation when only the currents are changed.
There can be several conductors wired to the same supply.

There is one object, with default name “Current”, which keeps track of all
the currents. To modify the currents, use the Modify menu to summon an
edit dialog for this object.

The Current object also allows you to specify a bias magnetic field (section
7).



3 Menus

3.1 File menu

New If no configuration window exists, creates a new one. There can only
be one configuration window.

Open Open a configuration file.

Close Close the configuration (if a window is active other than the config-
uration window, that window is closed).

Save Write the changed configuration to the file.

Print... Nothing fancy, but prints the configuration picture.

When a probe result window is active, the Export Data... command can
be used to write the calculated field to a specified file.

3.2 Edit menu

The functioning of the Edit menu depends on which type of BiotSavart
window is the active one. When the configuration window is the active one:

Cut (88X) Copies selected objects to the clipboard and deletes them.
Copy (88C) Copies selected objects to the clipboard.

Paste (§8V) Objects on the clipboard are loaded into the configuration.
Clear Deletes the selected objects.

Select All (88A) Selects all objects in the configuration.

Select None Clears the selection list.

Duplicate (§8D) Duplicates the selected objects.

Modify (38I) Creates a edit window for each selected object.

Visible Makes selected objects visible.
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Invisible Makes selected objects invisible.

Name... Allows you to specify a name for each selected object.

If no objects are selected, then Copy places a copy of the picture in the
configuration window onto the clipboard.

When an object’s edit window is active, then the Edit menu can be used to
Cut, Copy, and Paste text. Also, the Visible, Invisible, and Name...
commands can be used (they apply only to the object belonging to the
window in this case).

When a probe result window is active, then the Copy command copies a
picture of the graph to the clipboard. It is not possible to copy the calculated
field data. Export it to a file instead, using Export data... on the File
menu.

3.3 Config menu

The Config menu is used to add conductors or probes to the configuration.
It is also used to read conductors from other BiotSavart documents.

The Make conductor submenu creates conductors, or sources of magnetic
field:

Loop Circular filamentary loop, with fields calculated exactly using Elliptic
Integrals.

Solenoid Cylindrical solenoid. Fields are calculated by breaking the solenoid
up into loops and summing the loop fields.

Revolved Cylindrically symmetric current sheet obtained by revolving a
polygon about the symmetry axis. The surface current density pro-
duces the field of a permanent magnet of the specified shape. Fields
are calculated as a sum over loops.

Wire Creates a string of filamentary segments, specified by a sequence of
motion commands for a shuttle. These commands include straight
segments and radiused turns. Fields are calculated by summing the
exact fields from the segments.
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Racetrack Creates a planar racetrack conductor. Fields are calculated by
decomposing the Racetrack into a bundle of wires.

The Make probe submenu creates objects which measure the magnetic
field:

Linear Creates a one-dimensional field probe, which calculates the mag-
netic field along a specified trajectory and plots the (vector) field pro-
file.

Planar Creates a two-dimensional field probe, which calculates the mag-
netic field on a specified flat surface and displays a contour plot of the
field magnitude.

Other commands on the Config menu are

Read File... Reads the conductors from an existing BiotSavart document
or user-generated file (see section 9).

AutoSave If ticked, changing a conductor or probe via an edit dialog will
result in a write of the entire configuration to disk. Normally off.

3.4 Modify menu

The names of all objects (current supply caretaker, conductors, and probes)
appear on the Modify menu. Selecting a name from the menu selects the
object and creates an edit dialog for you to modify it. The current supply
caretaker is only accessible through this menu.

This menu also shows the selection list: the names of selected objects in the
configuration are ticked.

3.5 Field menu

The Field menu controls the recalculation of magnetic field. There are two
menu items:

12



AutoRecompute If ticked, the program will recalculate the magnetic field
whenever a conductor or probe is altered. Selecting AutoRecompute
will toggle it between ticked and not ticked. Ticking it when the field
needs to be recalculated will initiate the recalculation.

Recompute (38R) Used to trigger recalculation if AutoRecompute is not
ticked. The Recompute command will only be enabled when the field
needs to be recalculated. Use this manual trigger if you want to make
changes to several conductors between recalculations.

3.6 Windows menu

Permits activation of windows which may or may not be visible. The first
window listed is the configuration window. Other windows are listed (case-
insenstive) alphabetically.

13



4 Windows

4.1 Configuration window

There is one configuration window, which displays a picture of the conductor
configuration you are working on:

project i ==——=PF|

GEIE

™

g <

Bia= coil

=5

The title of the window is the name of the configuration file.
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At the top of the window are several controls:

h‘ Sets the configuration window to select mode. The cursor will
be the usual arrow, and can be used to select an object by
clicking at it. The selected object will be colored red. Double-
click an object to edit it.

IE:{'-- Sets the configuration window to zoom mode. The cursor will
be a magnifying glass. Specify the zoom rectangle on the pic-
ture by moving to the upper left hand corner of the rectangle,
depressing the mouse button, dragging to the lower right cor-
ner, and then releasing the button. The picture will zoom in on
the rectangle. Clicking without dragging will zoom in on the
point specified. Clicking the mouse with the shift key depressed
zooms out instead of in.

Zooms back out so that all of the objects are visible.
Sets two-dimensional display mode.

Sets three-dimensional display mode.

@ Op

(3D mode only) Launches a viewing direction choice window.
Changing the view direction zooms the view out so that all
conductors are visible.

i

(3D mode only) Removes the hidden lines from the drawing.
This can be time consuming. Note that later changing the
viewing direction will put the lines back in, but that zooming
will not.

Objects are selected by clicking on them. When an object is selected, its
name appears at the bottom of the configuration window and the object
is colored red. Clicking on an object with the shift key depressed adds it
to the selection list, permitting selection of more than one object. Shift-
clicking a selected object removes it from the selection list. The names of
all conductors and probes are listed in the Modify menu, with selected
objects ticked. With the configuration window active, selected objects can
be cut, pasted to or copied from the Clipboard, or deleted or duplicated,
using the Edit menu. Selecting Modify (§68I) from the Edit menu creates
edit windows for the selected object(s). To select and edit a single object,
one can just double-click on it. If an object is not visible, the Modify menu
can always be used to bring up an edit window. This also selects the object.
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Using the Print... command on the File menu, the picture may be printed.
No effort has been made to have BiotSavart produce report-quality printed
output, however. It is recommended that to produce a report you copy the
picture to a word processor document. The Copy command, with no objects
selected, copies the picture to the clipboard. Also note that a conductor
copied to the clipboard is a text object which specifies the conductor. To
copy the text description of the entire configuration to the clipboard, do
Select All, then Copy.

4.2 ViewSet window

The ViewSet window is used to set
the direction from which we view
a three-dimensional picture. This
window, which is summoned using
the eye icon on the graphics window,
displays a globe with lines of lati-
tude and longitude. To set the view-
ing direction drag the small rectan-
gle on the globe. To align with a
coordinate axis, click on the coor-
dinate label (click with shift key de-
pressed to look from the other side).

4.3 Edit dialog windows

Modification of a particular conductor or probe is done through its Edit win-
dow, which is summoned by double-clicking the object on the configuration
window or by using the Modify menu. The name of the edit window is the
name of the object being modified. The use of edit windows is described in
section 5.

To change current supply values, summon an edit window for the Current
object (this can only be done via the Modify menu).

16



4.4 Probe result windows

The results of magnetic field probes are plotted in probe windows. The
name of the probe window is the name of the probe object preceded by the
symbol II. The format of the plots is specified in the dialog window of the
probe itself.

When the probe result window is active, the field profile may be written to
disk using the Export Data... command on the File menu.

For more details, see section 8.
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5 The edit dialog in detail

The edit dialog contains a number of pages of information, which depend on
the type of object being edited. For example, here is the edit dialog window
for a Solenoid, turned to the Specs page:

Bias coil

Page selector SPECs Position { Supply

Looks Calc MNotes

Solenoid

Conductor type

innerRadius
outerRadius .
Page contents Discard changes

length gcm
Implement & dismiss

Implement

The title of the edit dialog window is the name of the object being edited.
Below the title bar is the page selector, which controls which page of infor-
mation is displayed. To the right of the page contents is an indication of the
type of object being edited.

The control buttons are: Set (to implement the changes you have made
to the dialog boxes), Done (to implement the changes and close the dialog
window), and Cancel (to throw away the changes and close the dialog win-
dow). Note that Set changes the object irrevocably; Cancel only discards
unimplemented changes.

In the above picture, the edit dialog is set to the first page, Specs. We will
now go through all of the pages for a Solenoid, to see how things are set

up.
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5.1 Page Specs - general specifications

Bias coil —=—"—=———1|

Specs Fosition : Supply

Solenoid

innerFadius 1 1mim

outerRadius A21mm
Cancel

(e )

length gCm

The size and shape of the object is specified on the Specs page of the edit
dialog. For a Solenoid, these specifications are the inner and outer radius
of the coil, and its length (a thin solenoid has the inner radius equal to
the outer radius, a pancake solenoid has length equal to zero). All of these
parameters can have units.

Recognized units: m cm mm ft in
(default is m) meter 0.0lm 0.00lm 12in 2.54cm

Other objects can have rather different Specs pages. For instance, the Wire
conductor has a text pane where you describe the path of the wire through
space.

19



5.2 Page Position - position and orientation

Bias coil D—————=
Specs ;Pnsihnn sSupply
Looks  [Calc  {Wotes
Solenoid
oosition 0
positionY i
positiond 171

Cancel

eulerPhi 0] -

eulerTheta Qi

eulerFsi 0] S5et

The position of the conductor is specified by giving the laboratory frame
coordinates of the reference point of the conductor (for instance, the center
of a solenoid, or the origin of the object coordinate system for a wire). As
shown above, these coordinates can have units.

The orientation of the conductor is specified by three Euler angles, denoted
as follows:

¢ eulerPhi rotate object about z-axis
0 eulerTheta rotate about object z-axis

(i.e., bow towards object —y direction)
1) eulerPsi rotate about new object z-axis

For an axially symmetric conductor such as a loop or solenoid, v has no
effect on the calculated magnetic field. The Euler angle parameters are
specified in degrees. The conductor is rotated about the origin of its own
coordinate system.

20



5.3 Page Supply - the flow of current

Bias coil —=—"—=———1|

Specs Fosition §5upply

Solenoid

current|D main

currentScale |-1

Cancel

ireli ter (0.5
wireDiameter |0.3mm
G (_pone ]

winding 11455 s5et

The Supply page is where you specify which current supply to use for the
object. The name of the supply (no embedded blanks) should be entered in
the currentSupply box. An overall scale factor for the current is specified
by the currentScale. This can be set to -1 to reverse the connections. The
current supplies themselves are set by bringing up an edit window for the
Current object (using the Modify menu).

To indicate a number of windings use the winding parameter.

For bulky conductors (Solenoid and Racetrack) the wireDiameter parame-
ter also appears on the Supply page. The winding can be calculated from
the wireDiameter or visa versa. To specify which way the calculation goes,
click the arrow button till it points the right way. The wire packing which is
used in this calculation is determined by the setting of the packing button:

IE Square packing. The number of turns is calculated from the
wireDiameter by dividing the cross sectional area by the square of
wireDiameter, rounding to the nearest integer. In the inverse calculation

21



wireDiameter is not, of course, rounded to an integer.

1
Hexagonal packing. The way round wires like to be wound, a bit tighter
than square packing (the number of windings is a factor 2/4/3 larger).

Note that the packing button is only used to determine the relation be-
tween winding and wireDiameter, and does not change the grid of pseudo-
conductors which is used to calculate the field of a bulky conductor; this is
always a rectangular grid.
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5.4 Page Looks - object appearance

The Looks page is where the appearance of the object is controlled. Nothing
here will change the calculation of the magnetic field.

The visible checkbox changes the visibility status of the object on the
configuration window.

With the solenoid in the “standard” (i.e., default) orientation and the con-
figuration window on 2D drawing mode, the drawLoops checkbox will cause
the calculation loops to be drawn.

The number of angular steps used to draw the solenoid is given by the nphi
command. A range of angles, phiO to phil may be specified to draw a
“cut-away” view. This does not change the magnetic field, which is always
that of a complete solenoid.

23



5.5 Page Calc - field calculation

Bias coil —=—"—=———1|

Specs %Pnsitmn sSupply

Looks iEalc Motes

Solenoid

resolution 2mm

paraxialk 1mm Cancel

(e )

The details of the field calculation are specified by parameters on the Calc
page.

In general, the field is found by decomposing the solenoid into loops and
summing the loop fields. The finesse of this decomposition is set by the
resolution parameter. The resolution should be chosen wisely; too large
a value will give unrealistic fields, too small may make the calculation un-
bearably slow.

Near the axis it is possible to use an expansion in p (the distance to the axis)
which is exact in the limit that p tends to zero. The parameter paraxialR
is the value of p where the calculation switches to sum-over-loops. With
paraxialR zero, the expansion is used only on axis. With paraxialR neg-
ative, the loops calculation is always used.
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5.6 Page Notes - user comments

Bias coil

Specs Fosition : Supply

Looks Calc Motes

Solenoid
Useful reminders: ir

Uzse 204 for 3T central
field.

Cancel
Quenches at 204 (the real
coil, not the simulation!)

&

Every object has a Notes page, where you can keep comments, parameters,
etc. for future reference.
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6 Edit dialogs by object

6.1

Loop

Specs page A table of radius, altitude, and winding for a set of coaxial

loops. The altitude is just the z-coordinate of the loop in the object
frame. Both radius and altitude can have units. All loops have the
same wire diameter.

Looks page Although the field due to the loop is calculated using Com-

Calc

plete Elliptic Integrals, the loop is drawn using straight segments or,
if wireDiameter is not zero, using planar polygons. The number of
segments drawn is set by the nphi parameter, the range of angles is set
by phiO and phil (these angles are in degrees). The number of steps
around the wire cross section is set by nzeta. None of the parameters
on this page has any effect on the calculated magnetic field.

page The wireDiameter parameter, which has two effects. First, the
wire is drawn with the specified thickness. Second, the field divergence
associated with a filamentary conductor is avoided, since the field is
calculated assuming uniform current density within the wire (actually,
BiotSavart assumes a linear field gradient in the wire, which is equiva-
lent in the limit that the wire diameter is much smaller than the loop
diameter.)
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6.2 Solenoid

Specs page The innerRadius, outerRadius, and length of the solenoid.
All quantities can have units. For a thin solenoid, enter the same
dimension for innerRadius and outerRadius. For a pancake coil set
length to zero.

Current page The wireDiameter parameter appears here, and can be
used to calculate the winding parameter, or visa versa. The arrow
button indicates the direction of calculation and the packing button
can be set to square or hexagonal packing.

Looks page The number of segments used to draw the solenoid is set by the
nphi parameter and for cut-away views the range of angles drawn is

set by phiO and phil. These parameters do not influence the magnetic
field.

Calc page The resolution parameter determines how  many
(pseudo)loops are used to calculate the magnetic field: the coil
cross section is divided by resolution. For distances to the axis, p,
smaller than paraxialR, a cubic expansion in p is used. If paraxialR
is negative, the sum-over-loops calculation is always used.
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6.3 Revolved

The Revolved conductor type is a cylindrically symmetric current sheet
obtained by revolving a polygon about an axis. Since the revolved object
is used to represent a body uniformly magnetized parallel to its axis, the
surface current density is proportional to cos 8, where 6 is the angle between
the axis and the surface normal. The current obtained from the current
supply is interpreted as the magnetization pugM in tesla.

Description of the edit dialog pages:

Specs page On this page of the edit dialog, you describe the two-
dimensional polygon which defines the cross section of the object. The
description language is given below.

Supply page The current supply current (multiplied by currentScale and
by winding) is interpreted as the magnetization poM of the body, in
tesla.

Looks page The revolved polygon is drawn using nphi angular steps. The
value of nphi has no effect on the magnetic field.

Calc page The wireDiameter appears here. There are no wires, of course,
but this parameter is the diameter of the calculation loops, and can
be used to smooth the field variations at the surface of the sheet. The
reverse checkbox can be used to reverse the order of polygon vertices.

Now we discuss how to describe the polygon on the Specs page.

First you must specify the density of loops which will be used in the calcu-
lation of the magnetic field, by the command

resolution 0.5 mm

Units are optional; the default unit is meter.

Next, specify the polygon by giving the starting point and sequence of mo-
tions in the (x,z) plane. For example, a truncated cone with an on-axis
hole:

28



start 2 0 mm
goto 8 -6 mm
goto 1 -6 mm
goto 1 0 mm
close

The resolution can be changed during the specification to allow some
parts of the polygon to be described by a higher density of loops. The
polygon should be specified clockwise in the xz-z plane. If you specify it
counterclockwise, however, you can use the reverse checkbox on the Calc
page. It is possible to describe a multi-piece magnet with a second sequence
of commands beginning with start.

29



6.4 Wire

Specs page A text description of the current path in three-dimensional
space. For this description object coordinates are used, before Euler
angle rotation and translation to the final position of the object in the
laboratory frame. The path language is described below.

Calc page The wireDiameter is used to suppress divergence of magnetic
fields near the conductor. This does not affect the appearance of the
wire on the configuration window; it is always drawn as a filament.

Now we consider how to describe the path of the wire, on the Specs page.

We begin a wire by giving the starting point (in object coordinates)
start 2 0 0 cm ; we begin here

The units apply to all components of the vector. As always, the default
length unit is meters. Note that a semicolon means that the rest of the line
is a comment.! To draw a straight line segment we simply say where to go:

goto 0.5 0 0 cm

To make an arc, we can specify a center and normal. For example, if we are
in the z-y plane and want to turn about the z-axis, we set

center 0 0 O
normal 0 0 1

and then turn, starting at the present position. Before making the arc, we
must first specify the finesse of the turn:

dtheta 20 ; stepsize in degrees

Then the turn command is used to create the arc:

Do not use this for important information; use the Notes page instead.
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turn 90 ; angle in degrees

Another way to make an arc is use the axis command, which uses two points
to specify an axis. For example, to make the axis of rotation parallel to the
z-axis, but passing through x = y = 2cm, the command is

axis 220 cm 2 21 cm

The distance between the two points is immaterial (and note that the units
of a vector apply to all three components). After an axis command, the
turn command makes an arc about the specified axis.

A helix is simply a turn with pitch. The pitch is specified by giving the
length per turn

pitch 1mm

Since the main use of pitch is to make multi-turn windings, the turn com-
mand will accept turn units:

turn 5t

Finally, to close the wire (this is optional) the command is

close
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6.5 Racetrack

Racetracks are used in particle accelerators and neutral atom traps. Biot-
Savart implements planar racetracks.

Specs page The dimensions of the racetrack are specified by the length of
the straight sections (bars), the span (distance between bar axes), the
width of the conductor (in its plane) and its height (out of plane).
The turns at the ends of the racetrack are semicircular. This is ap-
proximated, both in drawing and field calculation, by finite angular
steps. The number of steps in the semicircle is given by the nturn
parameter. The field computation time is proportional to nturn+2, so
it is best to use a small number unless an accurate depiction of the
end fields is desired.

Current page The wireDiameter parameter appears here, and can be
used to calculate the winding parameter, or visa versa, just as for
a solenoid.

Looks page Checking the drawWires box causes the calculation wires to
be drawn.

Calc page The magnetic field is calculated by subdividing the racetrack
into filamentary wires. The finesse of the subdivision is given by the
parameter resolution. The number of calculation wires is the coil
cross section divided by the square of resolution (so choose it wisely).
Suppression of field divergence near the wires inside the conductor is
automatic.
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7 Current supplies

There exists an invisible object whose task it is to keep track of the settings of
the various current supplies connected to the conductors of the configuration.
To change the settings of the current supplies, bring up an edit window for
this object using the Modify menu.

Current —ce——mo-—

Supplies EBias ;ND’LES

Current
SUpply current
0 1 ais
fmain 20

g_tlﬂckup 10
|

7 (st )

In a new configuration, the default current supply, called “0”, is set at one
ampere. The current supply names can be any text not containing blanks
(or braces). Several conductors can use the same current supply; if so, they
are wired in series.

The bias parameter (on the Bias page) specifies a uniform bias field (in
Tesla, in the z direction) which is to be applied to the configuration.

Once you have modified the Current object, implement the changes using
the Set or Done buttons. If AutoRecompute is enabled, the magnetic
field will be recalculated immediately to reflect the new current supply and
bias field settings.
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8 Field probes

The field probes are used to investigate the magnetic field profile. Probes
are made in the same way as conductors, by choosing the appropriate type
from the Config menu. Field probes have associated with them a window
which displays the calculated field graphically. The name of the window is
the name of the probe object preceded by the symbol II, meaning product.
This section describes the parameters for the field probes, which control
both the placement of calculated points and the plotting of the results.

8.1 Linear probe

This probe calculates the magnetic field along a specified trajectory, and
plots the result. The field unit is tesla. To set the points at which the field
is calculated enter a path on the Specs page, like the following:

resolution 1 mm ; spacing of points

start 0 0 O ; starting point

goto 1.3 0 0 cm ; first segment

resolution 0.5mm ; spacing for second segment
goto 1.3 0 2 cm ; second segment

Points are placed uniformly on each segment, with points on the starting and
ending position, such that the points are no further apart than the present
resolution.

The plot itself is controlled from the Plot and Scale pages. By default, the
field magnitude |§ | is plotted versus the distance s along the line. The z, y,
or z components of the field can be plotted as well, with the abscissa given
by either x, ¥y, z, or the arclength s. Normally the plot is scaled to show all
the data. This can be changed by specifying a range on the Scale page or
by zooming directly on the probe result window.
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8.2 Linear probe result window

The linear probe result window shows a graph of the calculated magnetic
field. In selection mode (cursor an arrow) clicking on a point on a curve
tells you the field value. In zoom mode you can zoom in on any part of the
graph.

Double click on the axis labels to jump to the probe dialog, in order to
change what is plotted or manually change the plot range.

With the result window active, you can use the Export Data... command
(on the File menu) to write the calculated data to a file. You will be
prompted for the name of the file to be written. Each line of the file consists
of seven tab-delimited floating point numbers:

ry z By B, B, B

8.3 Planar probe

This probe calculates the magnetic field on a flat surface specified by two
displacement vectors @ and . To specify the grid of probe positions specify
the resolution in the @ and v directions on the Grid page of the probe edit
window, and the vectors 4 and ¥ on the Specs page.

On the Plot page you can choose whether the contour plot will be drawn
in a separate probe result window. On the Looks page you can specify to
draw the contours on the configuration window. Drawing in both places is
also a possibility:

On the contour plot result window, clicking the mouse will give the (bi-
linearly interpolated in the grid) field value. Clicking with the shift key
depressed gives the value of the nearest contour.

Only one component or the magnitude of the magnetic field may plotted at
a time. On the Plot page of the edit window you select which.

On the Scale page, you select the range (bmin, bmax). The default plot
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range is the entire range of calculated fields. If autoscaling is on, these
parameters will be determined from the calculated fields. The contour spac-
ing is the parameter called contour. If you specify contour as zero, the
contour spacing will be one tenth of the range. Contours always start at the
lower limit of the range, bmin.
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9 BiotSavart document format

This section describes the format of the cofiguration file. It is also the format
of the clipboard contents if you copy objects there.

The configuration file is a plain text file. The file contains a list of object
descriptions. Each description is a word giving the type of object, followed
by a brace-delimited character string opening on the same line and con-
tinuing till the matching brace. The character string contains the defining
commands for the object, typically starting with the object’s name:

type {
name {the name}
...further commands...

In the present software, the type is one of the recognized object types
(Current, Loop, Solenoid, Revolved, Wire, Racetrack, Linear, or
Planar). If the type is not recognized, the text between curly brackets
which follows it will simply be ignored. The commands depend upon the
type of the object, and are described in the next section.

The format of a command line is
command param

where param is a parameter. String parameters are quoted by braces instead
of quotes (which can’t be nested). Multiline strings are possible — once a
string is opened with a left brace, it continues until the matching brace is
found. For instance, the comment command contains the contents of the
Notes page of the dialog box:

comment {User’s notes, in file braces are
written like this: \} to avoid confusion.
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9.1

Commands

In the following n denotes an integer, x, y, etc. are floating point numbers
(possibly with units), ¥ a two or three-dimensional vector (possibly with
units at the end), and b is a Boolean value (0 or 1). Commands are not case
sensitive (i.e., positionx and positionX are the same command).

Object (Commands common to all objects)

name {the name}
comment {notes...}
positionX x
positionY y
positionZ z
eulerPhi ¢
eulerPsi o
eulerTheta 6
visible b

Current
supplies {supply table} see section 9.2

bias By

object name
the contents of the Notes page
origin of object coordinate frame

Euler angles (degrees)

draw object? (b = 0 suppresses drawing)

bias field (z direction)

Conductor (Commands common to all conductors)

Loop

currentSupply name
currentScale z
winding x
wireDiameter =z
nPhi n

phi ¢o ¢1

nZeta n
loops {loop data}

current supply name
current supply scale factor
number of turns

wire diameter

steps used to draw a circle
drawing range (degrees)

steps to draw wire circumference
see section 9.2
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Solenoid
innerRadius =
outerRadius z
length z
resolution z
paraxialR r
drawLoops

Revolved
path {2-D path...}
drawLoops
reverse

2-D path (used by Revolved)

resolution z
start v

goto U
center ¥
dtheta Af
turn 6

close

Wire

path {3-D path...}

used for calculation loop spacing
near-axis threshold for cubic expansion
show loops used in calculation (2-D)

See below for path commands
show loops used in calculation (2-D)
reverse polygon defined by path

loop spacing for later segements
starting position (object coordinates)

center for turn

used if resolution zero
0 in degrees

close polygon

See below for path commands

3-D path (used by Wire and Linear)

resolution x

start v
goto ¥
axis U7 ¥y
center ¥
normal ¥
pitch x
dtheta Af
turn 6
turn = t
close

marker spacing for later segments
(only meaningful for Linear)
starting position (object coordinates)
line segment to new position
define axis for rotations

define center

define normal

pitch, in advance/revolution
stepsize for turns, degrees

turn through angle 6, degrees
turn through x turns

close wire (optional)
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Racetrack

length z
span x
width =
height
resolution x
nturn n

Linear

path {3-D path...}
xRange x1 29
yRange B;1 DBs
plot ywvars vs zvar

Planar

grid n, n,
uX =

uyY
uz
vX
vY
vZ x
plotrange B; B
contour T
apartWindow b
drawContour b
drawGrid b

8 8 8 8

length of straight section

distance between straights

width width of conductor (in plane)
height (out of plane)

controls subdivision into wires
number of segments in end turn

set plotting range 1 < z < z2 m

set plotting range By < B < B> tesla
yvars is one or more of bx, by, bz, or b
avar is one of x, y, z, or s

grid mesh
x-component of 4
...etc.

set plotting range By < B < By tesla
set contour spacing to x tesla

plot in separate window?

draw contour on configuration window?
draw grid on configuration window?
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9.2 Source code examples

The Loop and Current objects are examples of objects which include a
table as part of their definitions. To represent a table we use nested strings.
For example, to have two loops, one of 2cm radius at z = 1 cm carrying 0.3A
and one with opposite current of 3cm radius at z = —5 mm, we have

Loop {
name {Two loop object}

currentSupply mySupply
loops {
{ {2cm} {lcm} {1} }
} { {3cm} {-5mm} {-1} }
}

Current {
supplies {
} { {mySupply} {0.3} }

For objects with a path description, e.g., the path of a Wire through space,
the path commands are in the string which is the argument of the path
command:

Wire {
name {a short wire}
path {start 0 0 O
goto 1 0 1 cm

}
}
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10 Compatibility issues

10.1 Application signature

The signature of BiotSavart 2.2 (BioT) is not the same as that of Biot-
Savart 2.1 (Biot). We did not register with Apple in time (oops)! The new
signature is official, but the fact that files created by BiotSavart 2.1 have a
different signature means that BiotSavart 2.2 will not be started up when
you double-click version 2.1 data files.

We have built in the following remedy: if you drag version 2.1 data files onto
the 2.2 application, it will upgrade their signature. You can do this with
more than one file at a time (only one will be opened, yet all signatures will
be upgraded).

10.2 Old configuration files

BiotSavart 2.1 data files had a different way of specifying objects. Version
2.2 should be able to read these files. A number of things to watch out for:

e The number of windings was not a distinct concept from current scale
in version 2.1, and now this is fixed you may need to change these
parameters for your old conductors.

e With version 2.2, you do not get to edit the configuration file directly,
and the comments you added with version 2.1 will be swept into the
Notes page of the object’s edit dialog which will be a bit confusing.

If you encounter any incompatibilities that we have overlooked and which
should be fixed, please let us know!
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